首页 > 学院 > 网络通信 > 正文

modem-aux配置教程

2019-11-04 20:56:24
字体:
来源:转载
供稿:网友

  maui-slt-01#show running-config
  Building configuration...
  
  Current configuration:
  !
  version 12.1
  service timestamps debug datetime msec
  service timestamps log datetime msec
  no service passWord-encryption
  !
  hostname maui-slt-01
  !
  aaa new-model
  aaa authentication login default local
  aaa authentication login NO_AUTHEN none
  aaa authentication ppp default local
  
  !--- This is the basic AAA configuration for PPP calls.
  
  enable secret 5
  !
  username admin password 0
  username maui-nas-03 password 0 cisco
  
  !--- Defines username for remote router (maui-nas-03) and shared secret password.
  !--- Shared secret(used for CHAP authentication) must be the same on both sides.
  
  !
  memory-size iomem 30
  ip subnet-zero
  !
  chat-script Dialout ABORT ERROR ABORT BUSY "" "AT" OK "ATDT /T" TIMEOUT 45 CONNECT /c
  
  !--- Sets up chat script "Dialout" used for the dialout connection on aux 0.
  
  modemcap entry MY_USR_MODEM:MSC=&F1S0=1
  
  !--- Modemcap (MY_USR_MODEM) will be applied to the AUX port line interface
  !--- This modemcap was created using the command:
  !--- modemcap edit MY_USR_MODEM miscellaneous &F1S0=1
  !--- Refer to the Modem-Router Connection Guide for more information.
  
  !
  interface Loopback0
  ip address 172.17.1.1 255.255.255.0
  !
  interface FastEthernet0/0
  ip address 172.16.1.1 255.255.255.0
  no keepalive
  duplex auto
  speed auto
  !
  
  ! <<-- irrelevant output removed
  
  !
  interface Async65
  
  !--- Async interface corresponding to the AUX Port.
  !--- This was determined using the show line command.
  !--- See External Modem Setup and Troubleshooting Tasks for more details.
  
  no ip address
  encapsulation ppp
  
  !--- Use PPP encapsulation over this link.
  
  dialer in-band
  dialer pool-member 20
  
  !--- Designate Async65 as member of dialer pool 20.
  !--- The command dialer pool 20 is specified in interface Dialer 10.
  
  async default routing
  
  !--- This permits routing over the async interface.
  !--- This is required for a routing PRotocol to run accross the async link.
  
  ppp authentication chap callin
  !
  interface Dialer10
  
  !---Dialer 10 is the logical interface for Dialer Pool 20.
  
  ip unnumbered Loopback0
  
  !--- Uses the Loopback 0 IP address.
  
  encapsulation ppp
  ip ospf demand-circuit
  dialer remote-name maui-nas-03
  
  !--- Specifies the remote router name.
  !--- This name must match the one used by the remote router for authentication
  
  dialer pool 20
  
  !--- Async 65 is a member of this pool
  
  dialer idle-timeout 900
  dialer string 81690
  
  !--- Defines the destination router's phone number
  
  dialer max-call 4096
  dialer-group 1
  
  !--- apply interesting traffic definition from dialer-list 1
  
  
  ppp authentication chap callin
  
  !--- Use CHAP authentication for incoming calls
  
  !
  router ospf 5
  network 172.16.1.0 0.0.0.255 area 0
  network 172.17.1.0 0.0.0.255 area 0
  network 172.22.1.0 0.0.0.255 area 0
  
  !---OSPF is used between the routers.
  !---A routing protocol is unnecessary if you configure the appropriate static routes.
  
  !
  ip classless
  ip route 0.0.0.0 0.0.0.0 Dialer10
  
  !--- Default route points to int dialer 10.
  !--- This is necessary since OSPF is not configured to send default routes.
  
  no ip http server
  !
  access-list 101 remark Define Interesting Traffic
  access-list 101 deny ospf any any
  access-list 101 permit ip any any
  dialer-list 1 protocol ip list 101
  
  !--- Use access list 101 for interesting traffic definition
  !--- This is applied to interface Dialer 10 using dialer-group 1
  
  !
  line con 0
  login authentication NO_AUTHEN
  transport input none
  !
  line aux 0
  
  !--- line interface for the AUX port
  
  exec-timeout 0 0
  
  !--- disable exec timeout on the interface
  
  script dialer Dialout
  
  !--- use chat script "Dialout"
  
  modem InOut
  
  !--- enable incoming and outgoing calls
  
  modem autoconfigure type MY_USR_MODEM
  
  !--- apply the modemcap MY_USR_MODEM that was configured previously
  
  transport input all
  stopbits 1
  
  !--- Improve throughput by redUCing async framing overhead
  
  speed 115200
  
  !--- The AUX port on the 2600 supports a speed of 115200.
  !--- Note: If you are routing through the AUX port, each character generates a
  !--- processor interrupt. This is an abnormally high load on the CPU, which can be
  !--- resolved by using a lower AUX port speed.
  
  flowcontrol hardware
  
  !--- configures RTS/CTS flow control
  
  line vty 0 4
  !
  no scheduler allocate
  end
  
  ##########################################
  maui-nas-03#show running-config
  Building configuration...
  
  Current configuration:
  !
  version 12.0
  service timestamps debug datetime msec
  service timestamps log datetime msec
  no service password-encryption
  !
  hostname maui-nas-03
  !
  aaa new-model
  aaa authentication login default local
  aaa authentication login NO_AUTHEN none
  aaa authentication ppp default local
  
  !--- This is the basic AAA configuration for PPP calls.
  
  enable secret 5
  !
  username admin password 0
  username maui-slt-01 password 0 cisco
  
  !--- defines username for remote router (maui-slt-01) and shared secret password.
  !--- Shared secret(used for CHAP authentication) must be the same on both sides.
  
  spe 1/0 1/7
  firmware location system:/ucode/mica_port_firmware
  !
  ip subnet-zero
  !
  isdn switch-type primary-ni
  mta receive maximum-recipients 0
  !
  controller T1 0
  
  !--- Primary T1
  
  framing esf
  clock source line primary
  linecode b8zs
  pri-group timeslots 1-24
  !
  
  ! <<-- irrelevant output removed
  
  !
  interface Loopback0
  ip address 172.22.1.1 255.255.255.0
  no ip directed-broadcast
  !
  interface Ethernet0
  ip address 172.22.53.105 255.255.255.0
  no ip directed-broadcast
  no keepalive
  !
  
  ! <<-- irrelevant output removed
  
  !
  interface Serial0:23
  
  !--- D-channel for T1 0
  
  no ip address
  no ip directed-broadcast
  encapsulation ppp
  isdn switch-type primary-ni
  isdn incoming-voice modem
  
  !--- This sends incoming async calls to the modems.
  
  fair-queue 64 256 0
  ppp authentication chap
  !
  
  ! <<-- irrelevant output removed
  
  !
  interface Group-Async0
  
  !--- Group-Async interface is used to aggregate the modems.
  
  ip unnumbered Loo


发表评论 共有条评论
用户名: 密码:
验证码: 匿名发表